پاک کردن دوره ای لاگ های User Manager

Telegram_GEEKBOY

یکی از امکانات خوب میکروتیک برای سازمان ها و شرکت ها با کاربر کم یا متوسط و نیازمند حسابداری اینترنت با امکانات محدودتر نسبت به نرم افزارهای مشابه حرفه ای User Manager می باشد که بر روی میکروتیک نصب می شود و نیازمند سیستم مجزا نمی باشد. این نرم افزار خوب و گاها بسیار کارگشا در مواردی برای میکروتیک مشکلاتی ایجاد می کند که می بایست با نوشتن اسکریپت های خاص آن موضوع مشکلات را به حداقل رساند. در این آموزش به یکی از این مشکلات که پر شدن هارد و اشغال شدن CPU به سبب حجم بالای لاگ های User Manager است می پردازیم.

در بسیاری موارد نیروهای پشتیبان برای پاسخگویی به کاربران و پیدا کردن مشکلات اهراز هویت و… به لاگ های Authorisation & Authorisation & Accounting در User Manager نیازمند می باشند، در صورت فعال شدن این لاگ ها بعد از مدتی با زیاد شدن تعداد لاگ ها حجم هارد را تماما اشغال می کند و بار بر روی CPU را به شدت افزایش می دهد.

مراحل انجام کار:

ساخت اسکریپت

Scripts

مطابق عکس بالا در Winbox به System > Scripts رفته و اسکریپتی به نام Rm_UM_log با منبع زیر ایجاد کنید.

:local Flag
:set Flag [/tool user-manager log find]
:if ([:len $Flag] > 0) do={/tool user-manager log print append file log;/tool user-manager log remove [/tool user-manager log find];}

نوشتن زمانبندی:

Scripts

مطابق عکس بالا زمانبدی را ایجاد کنید یا دستورات زیر را در ترمینال وارد کنید.

/system scheduler add name="Rm-U-log" on-event="Rm_UM_log" start-date=Sep/15/2010 start-time=07:30:00 interval=7d comment="GeekBoy.ir" disabled=no

در قسمت on-event اسم اسکریپت ایجاد شده می بایست وارد شود.

نکته: حتما ساعت و تاریخ میکروتیک ها تنظیم کنید و در صورت امکان از NTP سرور استفاده کنید تا ساعت و تاریخ میکروتیک بعد از Reboot تغییر نکند.

در صورت نیاز به حذف Session ها، تمام مراحل مطابق با آموزش ذکر شده در بالا می باشد و فقط در قسمت ساخت اسکریپت از منبع زیر استفاده کنید:

:local Flag
:set Flag [/tool user-manager session find]
:if([:len $Flag]>0) do={/tool user-manager session print; /tool user-manager session remove [/tool user-manager session find];}

منبع: persianadmins

اگر شما نیز به رشد دانش خود و به اشتراک گزاری آن با دیگران علاقه مندید می توانید به ما بپیوندید
1 نظر
  1. Maillot De Foot Enfant Pas Cher می گوید

    Very great post. thank you!

ارسال یک نظر

آدرس ایمیل شما منتشر نخواهد شد.

این سایت از اکیسمت برای کاهش هرزنامه استفاده می کند. بیاموزید که چگونه اطلاعات دیدگاه های شما پردازش می‌شوند.